Hello Guest July 16, 2024, 10:21:01 *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
 
Pages: 1 2 [3]   Go Down

Author Topic: "Liverpool Titanic" gone...  (Read 24631 times)

Third Mate

  • Forum member
  • Posts: 1600
Re: "Liverpool Titanic" gone...
« Reply #50 on: April 16, 2008, 04:53:04 »

Is this horn like Titanics horn ???

Tanks for the horns capitan best, horn2 found its home with Ocean star, she sounds mean :D
Logged


THE 888 MARK
THE 999 MARK
THE 1111 MARK

RMS Gigantic

  • Forum member
  • Posts: 2601
Re: "Liverpool Titanic" gone...
« Reply #51 on: April 16, 2008, 14:56:40 »

Uh huh, i think it's real, well it was in the movie right?I mean i have heard 3 different whistles from Titanic with this one now.

SS08 horn
Movie Horn
And the one from Mary janes website/Youtube, so which is real one here?


Gee i was confused about the wheel house roof, because in half of the pictures involving the Titanic's wheel house roof, they are have a wooden roof, and in the other half the have a white roof.In the movie to, in half of the movie(begging) you can see the wheel house roof having wooden planks, and the other half of the movie it's white.Man, the world is confusing..... ??? :-X
A little something to remember if you're confused:

When in doubt, NEVER GO TO THE MOVIE!

That movie screws everything up!

I have a book on how to make a copy of the most accurate Titanic model in the world (but I'm no good at model making. It works mainly with wood, if anyone's interested!), and I could prove the movie wrong on soooooooooo many things with this baby! Anyway, the wheel house roof is white.

As for the horn, that was used in ss06 AND youtube, causing me to believe that was it.
Logged

Captain Best

  • Forum member
  • Posts: 3237
Re: "Liverpool Titanic" gone...
« Reply #52 on: April 16, 2008, 19:27:19 »

Tanks for the horns capitan best, horn2 found its home with Ocean star, she sounds mean :D
;D im finding everything ;D
Logged

mvsmith

  • Guest
Re: "Liverpool Titanic" gone...
« Reply #53 on: April 17, 2008, 22:25:51 »

I have found a picture if the bridge of the Titanic.Now according to this the ship had only 4 telegraphs instead of 5 and if you look at the steering wheel it has like a floor support wooden thing to step on.


That is actually a picture of Olympic’s bridge. No similar picture for Titanic exists. That is the picture used by Jim Cameron’s art department. The full frame shows part of a fifth telegraph on the port side.
Marty
Logged

RMS Gigantic

  • Forum member
  • Posts: 2601
Re: "Liverpool Titanic" gone...
« Reply #54 on: April 18, 2008, 03:48:19 »

The ships also lacks the squash courts that sprinkled the decks!

What if I compiled all the errors we found here and posted it on the development corner board?
Logged

RMS Gigantic

  • Forum member
  • Posts: 2601
Re: "Liverpool Titanic" gone...
« Reply #55 on: April 18, 2008, 03:50:00 »

oh, and the weather-sheilded section of the prominade deck should have windows.
Logged

Third Mate

  • Forum member
  • Posts: 1600
Re: "Liverpool Titanic" gone...
« Reply #56 on: April 18, 2008, 05:21:28 »

The ships also lacks the squash courts that sprinkled the decks!

What if I compiled all the errors we found here and posted it on the development corner board?

Acualy that is not a bad idea, it will make the subject stand out  big time, and it will be put on the "Must TO DO LIST" right at the top.All these errors really need to be fixed, REALLY :-X.
Logged


THE 888 MARK
THE 999 MARK
THE 1111 MARK

RMS Gigantic

  • Forum member
  • Posts: 2601
Re: "Liverpool Titanic" gone...
« Reply #57 on: April 18, 2008, 13:19:25 »

Acualy that is not a bad idea, it will make the subject stand out  big time, and it will be put on the "Must TO DO LIST" right at the top.All these errors really need to be fixed, REALLY :-X.
OK! PUT 'EM ALL ON THE DEVELOPMENT CORNER IT IS!

Please wait...
Logged

RMS Gigantic

  • Forum member
  • Posts: 2601
Re: "Liverpool Titanic" gone...
« Reply #58 on: April 18, 2008, 14:52:30 »

oops! almost forgot to provide a link to the thread!

http://www.shipsim.com/ShipSimForum/index.php/topic,7179.msg78209.html#new
Logged
Pages: 1 2 [3]   Go Up
 
 


SMF 2.0.14 | SMF © 2017, Simple Machines