Hello Guest November 15, 2018, 01:03:41 *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
 
Pages: [1] 2   Go Down

Author Topic: Crash  (Read 6673 times)

evebri1

  • Forum member
  • Posts: 184
Crash
« on: April 17, 2013, 16:16:23 »

Impossible de rentrer sur le jeu ???? :evil: :evil:

Alors que je n'ai rien changer au PC.

Toujours le même message

Logged
Bon vent , bonne mer

LucAtC

  • Ship Simulator Developer
  • Global Moderator
  • Posts: 2104
Re: Crash
« Reply #1 on: April 18, 2013, 17:39:16 »

Bonsoir evebri1,

Windows se change bien tout seul, il n'a besoin de personne pour ça. C'est probablement un autre programme qui a modifié quelque chose, codecs, runtimes de VC++ ou autres processus plus ou moins cachés.
Ré-installer d'abord les pilotes de la carte graphique si c'est une carte NVidia, ou alors le tout dernier ATI, mais alors vraiment le plus récent.
Ensuite DirectX complet, pour avoir les bons codecs, Windows s'occupe là aussi tout seul de trouver ce qu'il faut.
Sinon, désinstaller et tout réinstaller, après avoir sauvegardé le répertoire C:\Users\MonNom\Mes Documents\ShipSimExtremes Userdata, qui ne devrait en principe rien qui causerait le crash.

Bonne chance,
Luc
Logged

evebri1

  • Forum member
  • Posts: 184
Re: Crash
« Reply #2 on: April 23, 2013, 14:30:57 »

Merci Luc

je vais essayer

Bien à toi
Logged
Bon vent , bonne mer

thecarbu

  • Forum member
  • Posts: 47
Crash SSE
« Reply #3 on: August 20, 2013, 18:49:45 »

Bonjour, même chose, je viens de ré-installer SSE sur un Win 7 x 64 tout neuf...

dxdiag joint.  cdt


Carbu
Logged

LucAtC

  • Ship Simulator Developer
  • Global Moderator
  • Posts: 2104
Re: Crash
« Reply #4 on: August 20, 2013, 20:49:11 »

Bonjour Carbu,

Il ne devrait y avoir aucun problème si tout ce qui a été évoqué ci-dessus a été vérifié. Mais peut-être faut-il résoudre un problème de compatibilité, ou les composants DirectX9 nécessaires seraient manquants?

Bons essais,
Luc
Logged

thecarbu

  • Forum member
  • Posts: 47
Re: Crash
« Reply #5 on: August 20, 2013, 21:54:08 »

toujours pareil :

re-installation de SSE
mises à jour de runtime 2005
drivers vieux de 3 jours,
DX9 réinstallé : nada :

progression 57%, puis 71% puis initialisation et là plante systématiquement ...

je sèche...
cdt
Logged

LucAtC

  • Ship Simulator Developer
  • Global Moderator
  • Posts: 2104
Re: Crash
« Reply #6 on: August 20, 2013, 23:07:33 »

Une dernière possibilité est que PhysX n'est pas bien installé, on le trouve au même endroit que l'install de directX9 et de vcredist : C:\Program Files (x86)\Vstep\ShipSimExtremes\Resources\redist
Sinon, il faudra faire d'autres recherches!
je sèche aussi, si quelqu'un d'autre a une idée, elle serait la bienvenue.
cdt
Luc
Logged

thecarbu

  • Forum member
  • Posts: 47
Re: Crash
« Reply #7 on: August 21, 2013, 07:00:37 »

J'ai dégagé VB 2005 pour que SSE l'installe, re installé DX, re installé physX... y a t' il une version de VB 2005 à fuir ???

sinon, toujours pareil : progression 57%, puis 71%, initialising et patatra, SSE retourne chez sa mère...

désolant...
Logged

thecarbu

  • Forum member
  • Posts: 47
Re: Crash
« Reply #8 on: August 21, 2013, 07:04:32 »

nouveau message au lancement : customValueOperator.dll ???
Logged

LucAtC

  • Ship Simulator Developer
  • Global Moderator
  • Posts: 2104
Re: Crash
« Reply #9 on: August 21, 2013, 13:27:11 »

Il est bien entendu question de Visual C++ 2005 pour Windows 32 bit, pas de VB. Les runtimes de VC++ 2005 32 bit sont nécessaires, mais pour un système 64 bit il faut installer un KB comme expliqué auparavant.
Après sa diffusion, cette correction avait elle-même été modifiée, ce qui avait entraîné certains quiproquos/problèmes si le Windows Update n'était pas activé à ce moment-là sur les windows 64 bit.
Les runtimes de VC++2005 x86 sont indispensables, autant que la mise à jour pour un pc 64 bit.

Espérons que ce soit ça le problème...
Luc
Logged

thecarbu

  • Forum member
  • Posts: 47
Re: Crash
« Reply #10 on: August 21, 2013, 16:48:52 »

je voulais bien sur VC au lieu de VB, mais j'ai déjà tenté la manip sans résultat...

cdt
Logged

thecarbu

  • Forum member
  • Posts: 47
Re: Crash
« Reply #11 on: August 21, 2013, 21:18:24 »

et Java ??
Logged

LucAtC

  • Ship Simulator Developer
  • Global Moderator
  • Posts: 2104
Re: Crash
« Reply #12 on: August 21, 2013, 22:03:30 »

Java? Qu'est-ce que tu fais là, entre les deux bras d'un accordéoniste ... ou dans ShipSim Extremes? Il n'y a rien qui soit développé en Java dans Extremes, même s'il est possible qu'une application Java puisse interférer, mais c'est peu probable. Désactiver Java par son panneau de configuration permettrait de le vérifier.

Bonne soirée,
Luc
Logged

thecarbu

  • Forum member
  • Posts: 47
Re: Crash
« Reply #13 on: September 03, 2013, 17:36:29 »

toujours pareil malgré la nouvelle mise à jour....
Logged

LucAtC

  • Ship Simulator Developer
  • Global Moderator
  • Posts: 2104
Re: Crash
« Reply #14 on: September 03, 2013, 21:21:08 »

La mise à jour ne modifie en effet pas la compatibilité avec Win7 64 bit, heureusement. Mon PC est lui aussi Win7 64 bit, et le seul problème que ShipSim Extremes a eu il y a déjà pas mal de temps est un démarrage fort lent, avec un temps d'attente fort long après les 71%.... mais depuis la version 1.5, et avec un SSD c'est devenu très acceptable.
L'erreur de CustomCommand.dll provient en tout cas avec une quasi-certitude de la présence d'une mauvaise version des runtimes VC++2005 x86, donc le vcredist_x86.EXE (32 bit), sur un Win7 64 bit, comme expliqué dans http://80.95.161.114/shipsim/forum/index.php/topic,29262.0.html. Que la manip d'installation échoue est évidemment possible, mais en principe Windows Update doit s'arranger des pare-feux ou antivirus sans problème, et je n'ai aucune idée de ce qui peut faire échouer la mise à jour, c'est peut-être un problème d'installation des mises à jour.
Je ne vois rien d'autre, hélas.

Bonne chance,
Luc
Logged

thecarbu

  • Forum member
  • Posts: 47
Re: Crash
« Reply #15 on: September 03, 2013, 21:53:10 »

je viens de désinstaller Vc+2005 x86 de ma machine. Installé la version indiqué dans ton précédent message.
Aucun changement "57%", "71%", "initialising" et badaboom...
Logged

thecarbu

  • Forum member
  • Posts: 47
Re: Crash
« Reply #16 on: September 03, 2013, 23:10:35 »

dernier essai :

1- désinstallation de SSE, désinstallation de VC++ 2005 et un coup de CCLeaner + redémarrage du PC
2- installation de SSE + les MAJ + redémarrage :  "Customcommand.dll"
3- installation de vcredist_x86 32bit + redémarrage
4- lancement de SSE : 57%... 71%.... initialising et fin de la partie, retour à la case départ : impossible de lancer ce jeu... :evil:

fichier joints éventuellement.

cdt
Carbu
Logged

LucAtC

  • Ship Simulator Developer
  • Global Moderator
  • Posts: 2104
Re: Crash
« Reply #17 on: September 04, 2013, 00:29:14 »

Apparemment, l'installation du vcredist_x86 règle bien le Customcommand.dll, ce qui signifie que VC++ fonctionne normalement. L'échec se passe au moment du passage de la carte graphique à DirectX ou à PhysX qui sont bien installés?
Les DxDiag de mon PC sont -toutes autres choses égales par ailleurs- quasi les mêmes, à ceci près
       D3D9 Overlay: Not Supported
            DXVA-HD: Not Supported
au lieu de Supported, mais est-ce que cela signifie quelque chose?
Ou encore installer une version récente de PhysX? Vérifier les réglages de la carte graphique.
Complètement au bout de mes possibilités!
Il faudrait que quelqu'un qui a déjà rencontré le problème et l'a résolu vienne nous confier ses idées.
Je regrette,

Bonne soirée
Luc

PS: A tout hasard, n'aurais-tu pas omis de faire le unregister.exe pour rétablir les inscriptions dans la base de registre?
« Last Edit: September 04, 2013, 09:15:42 by LucAtC »
Logged

Ghost025

  • Forum member
  • Posts: 1
Re: Crash
« Reply #18 on: September 04, 2013, 00:44:59 »

HOW DO I GET FORUM THING it wont let me play im so ANGRY! :(
Logged

LucAtC

  • Ship Simulator Developer
  • Global Moderator
  • Posts: 2104
Re: Crash
« Reply #19 on: September 04, 2013, 09:28:50 »

Hello Ghost025,

Welcome, I see that it is your first post, you should have posted it in one of the English boards to increase your chances to get an answer. Also, what do you exactly want? Is it something about ShipSim 2008 or Extremes?
Eventually, you should register the key of your game, it would give you access to all the boards of the forum:
At the top of this page, there is a yellow band, click on "Profile", a new page will open where you should enter the license key of your game(s).

Regards,
Luc
Logged

thecarbu

  • Forum member
  • Posts: 47
Re: Crash
« Reply #20 on: September 04, 2013, 14:42:21 »

PS: A tout hasard, n'aurais-tu pas omis de faire le unregister.exe pour rétablir les inscriptions dans la base de registre?

A quel moment de mon processus de désinstallation - installation faut-il faire cette manip ??


a+
« Last Edit: September 04, 2013, 14:44:45 by thecarbu »
Logged

LucAtC

  • Ship Simulator Developer
  • Global Moderator
  • Posts: 2104
Re: Crash
« Reply #21 on: September 04, 2013, 18:34:57 »

Si la correction des runtimes VC++ 2005 x86 est faite, avant de démarrer le jeu. Au lancement, il rétablira les inscriptions nécessaires correctement.

Croisons les doigts
Logged

thecarbu

  • Forum member
  • Posts: 47
Re: Crash
« Reply #22 on: September 04, 2013, 19:01:38 »

ça ne marche pas... >:(


quand utiliser unregister.exe ???
Logged

LucAtC

  • Ship Simulator Developer
  • Global Moderator
  • Posts: 2104
Re: Crash
« Reply #23 on: September 04, 2013, 22:25:15 »

C'est que ce n'est pas la raison. Il faut utiliser unregister quand des changements ont été introduits à l'application, changements enregistrés. C'est donc à faire avant une réinstallation, pour nettoyer la base de registre des clés qui renverraient à des emplacements erronés.
La clé de licence complexe est ainsi aussi effacée, ainsi que le dossier des userdata dont il faut garder une copie pour récupérer les fichiers utilisateur, dont Settings.xml dans le répertoire Profiles pour éviter de devoir recommencer la configuration du clavier et autres gamepads.

Mais je suppose qu'il y a autre chose, même une corruption de fichiers pour l'une ou l'autre raison, il faudrait peut-être re-télécharger? En effet, Win7 à jour avec ses updates, les pilotes de carte graphique récents, un DxDiag correct, PhysX activé, sur ton système ça doit fonctionner. Il reste encore la question des filtres DirectShow, à remettre dans le bon ordre grâce à K-Lite codecs par exemple.
Peut-être un problème matériel, de mémoire par exemple, franchement, je tombe à court d'idées et de bonnes questions.
J'installe, déinstalle et ré-installe fréquemment SSExtremes ou Nautis sans problème, que ce soit de Windows ou de l'application. Reste encore ceci, quel est l'antivirus qui autorise le programme?

bonsoir,
Luc

Logged

thecarbu

  • Forum member
  • Posts: 47
Re: Crash
« Reply #24 on: September 04, 2013, 22:54:30 »

ok ça donne des idées. moi aussi 1ere fois que j'ai ces problèmes.

pour l'antivirus c'est Microsoft security essential.


bonne soirée

Carbu
« Last Edit: September 04, 2013, 23:31:16 by thecarbu »
Logged
Pages: [1] 2   Go Up
 
 


SMF 2.0.14 | SMF © 2017, Simple Machines